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Make graffi ti in your own style by 

 

building handwritten font sets in Photoshop, 

Illustrator CS2 and Fontographer…

M
ost of us walk, cycle or drive past 
graffi ti for most of our lives, often 
without even being aware of the 
tags, outlines and pieces in our 

urban environment. Graffi ti is strategically 
placed on buildings and billboards that are 
impossible to overlook, or in obscure spots that 
are like little treasures when discovered. 
 As the graffi ti movement inspired by 1970s 
New York has spread across the world, each 
city or region has developed a distinct style, 
providing plenty of inspiration for the observant 
designer. In this tutorial, we’re going to use 
some of these ideas to create a graffi ti font.
 If you already have a graffi ti style of your own 
or know a graffi ti writer who can produce some 

lettering for you, then the work will be easy to 
convert into a font. If you are less familiar with 
graffi ti, grab your camera and get outside. Take 
pictures of graffi ti letters, tags, throwups – 
whatever pieces you fi nd that capture your 
attention – and begin to practise the different 
styles by hand until you fi nd one you are 
pleased with. In doing so, you’ll quickly realise 
the close relationship graffi ti shares with 
typography and graphic design. 
 If you are itching to make your own graffi ti 
font and do not have the time to create your 
own, there’s a hand-styled design on the CD so 
you can get started. To complete this tutorial 
successfully, you must be competent in 
Fontographer, Photoshop and Illustrator CS2.

Expertise provided by Stephen Faustina, the art director on Francis Ford Coppola’s 
All-Story magazine and a mainstay of graffi ti culture, both in conventional media and 
on the street. See more at [w] www.sfaustina.com.

The components needed to complete this tutorial can be found on the Computer Arts Projects 
disc 81 in the DiscContent>Tutorials>Tutorial Files>Graffi ti Fonts folder.

CAP81.tut_font   73CAP81.tut_font   73 13/1/06   6:31:17 pm13/1/06   6:31:17 pm



74 Tutorial Graffi ti fonts  

Biting

Any graffi ti you gravitate to is 

solely a piece of inspiration to 

get you creating your font set. In 

graffi ti culture, to directly copy a 

writer’s letters or style is referred 

to as biting. We’ve provided few 

examples, taken in San 

Francisco, on the CD: look in 

the Inspiration folder.

1
Now that your letters have been traced and 
vectorised, you will need to ungroup all the 

letters. With all the letters still selected, go to 
Object>Ungroup. Deselect the letters. 

2
Save this Illustrator fi le and name it 
letterstage.ai. At this point, we are going to 

start building our fi rst letter of the alphabet. Keep 
the letterstage.ai document open, then create a new 
Illustrator document: name it A.eps and make the 
artboard A4 with a landscape orientation.

3
We must change this fi le to an Illustrator 3 EPS 
to enable its import into Fontographer. Select 

File>Save As from the Format dropdown menu, then 
select Illustrator EPS and click Save. The EPS Options 
window will open. Select Illustrator 3 EPS from the 
Version dropdown menu and click OK.

Part 2: Building your alphabet
Make a template so your font set is consistent

Part 1: Getting started 
Design a character set and convert to vector-based shapes

1
Test out different felt pens, such as pilots, paint 
pens and ultrawide markers. The darker the ink 

is, the easier it is to convert to vector. Explore ink 
fl ows and tip thicknesses: these can contribute to 
your own graffi ti hand style. Keep repeating the 
alphabet, including arrows, asterisks or simple 
characters you want in your graffi ti font set.

2
After you have found a pen and a style you 
are comfortable with, start writing out your full 

character set in sequence. Make sure the letter size 
and styling stays consistent: pay attention to 
consistency in shapes such as ascenders and 
descenders. The CD includes examples for reference 
or to use in the rest of this tutorial.

3
Scan the sketches into Photoshop in greyscale 
mode at 300dpi. If you are using the CD 

examples, open beef.jpg in Photoshop. Now we’ll 
darken the letters so they are solid black, making it 
easier to convert the letters to vector. Choose Image
>Adjustments>Levels. Set the input levels to 100, 
1.00 and 215. Select Layer>Flatten Image.

4
Using the Eraser tool, clean up the corners and 
any spots, dust and pencil marks you fi nd 

around each letter. Smooth out any abrupt 
inconsistencies in the line, ready for when the letters 
are converted to vector. When satisfi ed, save the fi le 
as beef.tif and close. 

5
Now launch illustrator CS2 and open the 
beef.tif fi le. Next, we are going to make the 

letters into vector art with the new Live Trace 
feature in Illustrator CS2. If you don’t have 
Illustrator CS2, you can make your vector in either 
Streamline or Corel Trace.

6
To make your vector in Illustrator CS2, select 
the letter fi le and go to Object>Live Trace

>Make And Expand. If a dialog box appears saying, 
“Tracing may proceed slowly”, click OK to 
continue. Illustrator now converts each shape to 
a vector.
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1
Open your saved A.eps fi le. We need to clear 
all the guides, because Fontographer will have 

problems with these when it imports the EPS fi les. 
Go to View>Guides>Clear Guides. Save the fi le and 
close. Well done: you’ve just completed your fi rst 
graffi ti letter.

2
With the letterstage.ai fi le still open, we are 
going to reopen the base.eps fi le that we 

created earlier. You should have a blank document 
with guides.

3
Go back to the letterstage.ai fi le and 
select the letter B, making sure you select 

only the points forming the B. Drag it to the 
base.eps fi le.

Straight-letter 

styling

On the CD, SKERT is an example 

of a straight-letter graffi ti style: 

the letters are neither bubble-

style, common in throwups, nor 

abstract, common to piecing. 

If this is the style you want to 

achieve, this is a great photo to 

work from. 

Part 3: Creating more letters
Make individual fi les for each character in your font set
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Building your alphabet continued...

4
In the A.eps fi le, use the Rectangle tool to 
create a 3x3-inch 1pt stroke with no fi ll square 

in the middle of the artboard.

5
Go to your letterstage.ai document. With the 
Selection tool, select the letter A from your 

alphabet. Make sure not to select any of the white 
mask area that was created during Live Trace, and 
also make sure only the points forming the letter A 
are selected. 

6
Drag the selection onto the A.eps document 
and position the letter in the middle of the 

3-inch square.

7
Now drag in guides around each side of the 
letter A, enclosing the area it occupies, and 

save the A.eps fi le. 

8
We will now use this document and its guides 
as a template to be used for the remaining 

characters, as well as for future fonts. Delete the 
letter A, then use Save As to save a new version 
of the fi le, naming it base.eps. Make sure it’s an 
Illustrator 3 EPS, as you did before.

9
The area defi ned by the guides will be used for 
each letter hereafter: the top and bottom of 

each letter needs to fi t within the guides. If a letter 
is too small or too big, we’ll simply scale it to fi t 
within the guides. Now close the base.eps fi le.
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Overlapping letters

On the CD, ADIOS demonstrates 

a key element of graffi ti, the use 

of overlapping letters. Rarely will 

you fi nd on the streets a graffi ti 

writer who leaves behind their 

word without at least one pair of 

overlapping letters. If your goal is 

to achieve an authentic street 

feel for your font set, overlapping 

letter spacing is essential.

Creating more letters continued... 

4
Position the shape in the centre of the guides. 
Optically scale the letter to the same height as 

the A. Now go to View>Guide>Clear Guides. Use 
Save As to rename the fi le B.eps, then save it 
alongside your A.eps fi le, again making sure it’s an 
Illustrator 3 EPS. 

5
Repeat this procedure until you have all the 
letters for your alphabet. Save each letter as 

an Illustrator 3 EPS fi le, and name each letter 
accordingly. Remember to remove the guides before 
saving each letter: you can use Edit>Undo to 
reinstate the guides quickly, rather than reopening 
the base.eps fi le each time.

6
We are fi nished with Illustrator, and are now 
going to launch the Fontographer application. 

You can use Font Lab instead if you prefer. Once 
Fontographer is opened, select File>New Font. Your 
work area containing all related characters of a font 
will be in this window.

4
Double-click the capital letter A, opening 
another window with the Tool palette. We will 

now import the fi rst letter in the capital A character 
window. You can follow this technique to import 
any type of EPS graphic, including elements such as 
arrows and asterisks to enhance your font set.

5
Go to File>Import>EPS. Select the folder 
enclosing your characters, and choose A.eps. 

Click Open.

6
The A.eps letter fi le now appears in the middle 
of the window, showing you an outline 

preview of the letter. You’ll notice that the square 
we made around the A in the Illustrator EPS fi le is 
still there.

1
By default, the Fontographer work area 
window’s View mode should be Character 

mode: if it isn’t, change it now using the View By 
dropdown menu.

2
Name and save this Fontographer fi le as 
cabeef.fog. Now it’s time to make this graffi ti 

font offi cial by giving it a name.

3
Select Element>Font Info: the Font Info dialog 
box will appear. Under Family Name, type 

‘sfbeef’; under Style Name, type ‘graffi ti’. Click Okay. 
Now let’s prepare to import all the Illustrator letter 
fi les we made.

3D shadows

A 3D-effect shadow is an 

essential element of graffi ti: 

it makes the writing more 

noticeable. On the CD, OBCES 

is an example of frontward 3D 

shadowing. The best thing to do is 

experiment with shadowing until 

you are satisfi ed.

Part 4: Converting your font
Paying attention to font spacing will create a graffi ti-like feel later on
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1
After importing each EPS letter into its 
appropriate box, choose Edit>Select All. With 

all the letters selected, choose Element>Correct Path 
Direction: this will remove any overlapping shapes 
or unwanted paths. The last step is to generate the 
font fi le.

2
Select File>Generate Font Files. The Generate 
Font Files dialog box will appear: the Easy 

option should be selected by default. Under Type Of 
Font To Generate, choose between Mac or PC for 
the Computer option. For the Format option, select 
TrueType. Click the Generate button to fi nish.

3
Now load the TrueType fi le into your font library 
and test it out. Make sure the Caps Lock key is 

selected as you type: the graffi ti font is placed in the 
upper case character windows of Fontographer. You 
can always go back into your original cabeef.fog fi le 
to resize letters or adjust spacing.  

More inspiration

To get more ideas, check out the 

books Subway Art, Faith of 

Graffi ti, Getting Up, Spraycan Art 

and Bloodwars Volume One; and 

the videos Style Wars, Beat 

Street, Quality of Life, State Your 

Name, Piece by Piece and Wild 

Style.

Part 5: Finishing your font
It’s time to convert your characters into a true font

Converting your font continued...

7
Using the Selection tool from the Tool palette, 
we’ll delete the four corner points that make 

up the square. It’s easiest to delete two points at 
a time by dragging the cursor over the two top 
points and deleting, then repeating the step for the 
bottom two points. Make sure not to select any of 
the points forming the letter itself.

8
Now we are going to move the letter A to the 
left, creating graffi ti-style letter spacing for the 

fi nal font. With the Selection tool, highlight the 
entire A. 

9
Use the left arrow key on the keyboard to 
move the letter. You are going to move the 

letter until the letter slightly overlaps the left vertical 
line. Deselect the letter.

10
Pull the right-side vertical line to the right side 
of the A. The proximity of the lines to either 

side of the letter determines the letter spacing when 
the font is in use. Graffi ti writing is usually executed 
so that letters touch or overlap. Experiment with the 
spacing until you are satisfi ed.

11
The letter A is complete, so you can now close 
this window. Do the import and alignment 

procedures for the rest of your alphabet, 
remembering to import each letter into its correct 
letter window. Remember to save the cabeef.fog fi le 
periodically to preserve your work.

12
If a cross graphic appears in the window as you 
import any character, it means you forgot to 

delete the guides on your EPS fi le. Simply go back and 
clear the guides, then re-import the EPS fi le.

CAP81.tut_font   77CAP81.tut_font   77 13/1/06   6:31:47 pm13/1/06   6:31:47 pm


